FIX ERROR – MySQL: Your password does not satisfy the current policy requirements

When trying to set a password for the mysql user, the following error occurs:

ERROR 1819 (HY000): Your password does not satisfy the current policy requirements

 

This error appears if your password does not meet the following requirements, for "validate_password.policy" in "MEDIUM" mode it is:

  • Minimum length 8 characters
  • At least one digit
  • At least one uppercase letter
  • At least one special character

 

Solution:

1. Set a password that meets the security requirements for passwords.

2. Or lower the password security requirement level:

 

If the second option suits you, then log in to mysql and look at the current value:

mysql> SHOW VARIABLES LIKE 'validate_password%';
+--------------------------------------+--------+
| Variable_name                        | Value  |
+--------------------------------------+--------+
| validate_password.check_user_name    | ON     |
| validate_password.dictionary_file    |        |
| validate_password.length             | 8      |
| validate_password.mixed_case_count   | 1      |
| validate_password.number_count       | 1      |
| validate_password.policy             | MEDIUM |
| validate_password.special_char_count | 1      |
+--------------------------------------+--------+
7 rows in set (0.00 sec)

 

And lower the level:

SET GLOBAL validate_password.policy=LOW;
0 0 vote
Article Rating

Tagged: Tags

Подписаться
Уведомление о
guest
0 Comments
Inline Feedbacks
View all comments